EMA with Supertrend As Source

Supertrend is a trend following indicator which can be used to identify upward or downward
trends.

BUY{
SET ST = SUPERTREND(7,3,SIMPLE);
SET MA = EMA(ST,9);
MA > ST AND MA <= (ST * 1.005) AND CLOSE > MA;}

SELL{
SET ST = SUPERTREND(7,3,SIMPLE);
SET MA = EMA(ST,9);
MA < ST AND ST <= (MA * 1.005) AND CLOSE < MA;}

This slideshow requires JavaScript.

Advertisements

Relative Momentum Index (RMI) With WMA.

The Relative Momentum Index (RMI) is a variation of the Relative Strength Index (RSI). While the RMI counts up and down days from today’s close relative to the close n-days ago while the RSI counts days up and down from close to previous close.

BUY{
SET RM = RMI(CLOSE,50,9);
SET MA = WMA(RM,50);
CROSSOVER(RM,MA) AND RM < 20;}

LONGEXIT{
SET RM = RMI(CLOSE,50,9);
SET MA = WMA(RM,50);
CROSSOVER(MA,RM) AND RM > 60;}

SELL{
SET RM = RMI(CLOSE,50,9);
SET MA = WMA(RM,50);
CROSSOVER(MA,RM) AND RM > 60;}

SHORTEXIT{
SET RM = RMI(CLOSE,50,9);
SET MA = WMA(RM,50);
CROSSOVER(RM,MA) AND RM < 20;}

This slideshow requires JavaScript.

Swing Index (SI)

The Swing Index (Wilder) is a popular indicator that shows comparative price strength within a single security by comparing the current open, high, low, and close prices with previous prices.

BUY{
SET TP1 = TP();
SET MA = WMA(TP1,50);
SET SI1 = SI(2);
SET MA1 = EMA(SI1,21);
CROSSOVER(TP1,MA) AND REF(MA1,1) < 0.01 AND REF(CLOSE,1) > REF(OPEN,1);}

LONGEXIT{
SET TP1 = TP();
SET MA = WMA(TP1,50);
SET SI1 = SI(2);
SET MA1 = EMA(SI1,21);
CROSSOVER(MA,TP1) AND REF(MA1,1) > 0.01 AND REF(CLOSE,1) > REF(OPEN,1);}

SELL{
SET TP1 = TP();
SET MA = WMA(TP1,50);
SET SI1 = SI(2);
SET MA1 = EMA(SI1,21);
CROSSOVER(MA,TP1) AND REF(MA1,1) > 0.01 AND REF(CLOSE,1) > REF(OPEN,1);}

SHORTEXIT{
SET TP1 = TP();
SET MA = WMA(TP1,50);
SET SI1 = SI(2);
SET MA1 = EMA(SI1,21);
CROSSOVER(TP1,MA) AND REF(MA1,1) < 0.01 AND REF(CLOSE,1) > REF(OPEN,1);}

This slideshow requires JavaScript.

MACD WITH WMA

This trading system is based on MACD,WMA and CCI indicators.

BUY{
SET MCD = MACD(8,12,9,SIMPLE);
SET W13 = WMA(CLOSE,13);
SET W27 = WMA(CLOSE,27);
SET C1 = CCI(14,SIMPLE);
CROSSOVER(W13,W27) AND MCD > 0.01 AND C1 > 0.01;}

SELL{
SET MCD = MACD(8,12,9,SIMPLE);
SET W13 = WMA(CLOSE,13);
SET W27 = WMA(CLOSE,27);
SET C1 = CCI(14,SIMPLE);
CROSSOVER(W27,W13) AND MCD < 0.01 AND C1 < 0.01;}

This slideshow requires JavaScript.

Bollinger Bands Breakout and RSI Trading System

When the RSI is above 70, and when the Price drops above the Higher Bollinger Band.When the RSI is below 30, and when the Price drops below the Lower Bollinger Band.

BUY{
SET BT = BBT(CLOSE,20,2,SIMPLE);
SET RS = RSI(CLOSE,11);
RS > 70 AND CROSSOVER(CLOSE,BT);}

SELL{
SET BB = BBB(CLOSE,20,2,SIMPLE);
SET RS = RSI(CLOSE,11);
RS < 30 AND CROSSOVER(BB,CLOSE);} 

This slideshow requires JavaScript.

Trade Volume Index (TVI)

The Trade Volume index shows whether a security is being accumulated or distributed.

BUY{
SET TV = TVI(CLOSE,0.25);
SET MA = SMA(TV,21);
CROSSOVER(TV,MA);}

SELL{
SET TV = TVI(CLOSE,0.25);
SET MA = SMA(TV,21);
CROSSOVER(MA,TV);}

This slideshow requires JavaScript.

CANDLESTICK PATTERN CNTD.

BUY{
SET C1 = REF(CLOSE,1);
SET C2 = REF(CLOSE,2);
SET C3 = REF(CLOSE,3);
SET O1 = REF(OPEN,1);
SET O2 = REF(OPEN,2);
SET O3 = REF(OPEN,3);
O3 > C3 AND O2 > C2 AND O1 > C1 AND CLOSE > OPEN AND CLOSE > MAX(HIGH,4);}

LONGEXIT{
CLOSE > REF(CLOSE,1) * 1.022;}

This slideshow requires JavaScript.

Parabolic Stop and Reversal (Parabolic SAR)

Author Welles Wilder developed the Parabolic SAR. This indicator is always in the market (whenever a position is closed, an opposing position is taken). The Parabolic SAR indicator is most often used to set trailing price stops.

BUY{
SET PS = PSAR(0.2,0.02);
SET MA = EMA(PS,21);
SET MA2 = SMA(CLOSE,50);
CROSSOVER(MA,PS) AND CLOSE < MA2;}

LONGEXIT{
SET PS = PSAR(0.2,0.02);
SET MA = EMA(PS,21);
SET MA2 = SMA(CLOSE,50);
CROSSOVER(PS,MA) AND CLOSE > MA2;} 

This slideshow requires JavaScript.

Volume Oscillator (V.O.)

The Volume Oscillator shows a spread of two different moving averages of volume over a
specified period of time.

BUY{
SET VOS = VO(9,21,SIMPLE,PERCENT);
SET MA = EMA(CLOSE,21);
LOW > MA AND VOS > 20;}

LONGEXIT{
SET VOS = VO(9,21,SIMPLE,PERCENT);
SET MA = EMA(CLOSE,21);
HIGH < MA AND VOS > 20;}

SELL{
SET VOS = VO(9,21,SIMPLE,PERCENT);
SET MA = EMA(CLOSE,21);
HIGH < MA AND VOS > 20;}

SHORTEXIT{
SET VOS = VO(9,21,SIMPLE,PERCENT);
SET MA = EMA(CLOSE,21);
LOW > MA AND VOS > 20;}

This slideshow requires JavaScript.