Swing Index (SI)

The Swing Index (Wilder) is a popular indicator that shows comparative price strength within a single security by comparing the current open, high, low, and close prices with previous prices.

BUY{
SET TP1 = TP();
SET MA = WMA(TP1,50);
SET SI1 = SI(2);
SET MA1 = EMA(SI1,21);
CROSSOVER(TP1,MA) AND REF(MA1,1) < 0.01 AND REF(CLOSE,1) > REF(OPEN,1);}

LONGEXIT{
SET TP1 = TP();
SET MA = WMA(TP1,50);
SET SI1 = SI(2);
SET MA1 = EMA(SI1,21);
CROSSOVER(MA,TP1) AND REF(MA1,1) > 0.01 AND REF(CLOSE,1) > REF(OPEN,1);}

SELL{
SET TP1 = TP();
SET MA = WMA(TP1,50);
SET SI1 = SI(2);
SET MA1 = EMA(SI1,21);
CROSSOVER(MA,TP1) AND REF(MA1,1) > 0.01 AND REF(CLOSE,1) > REF(OPEN,1);}

SHORTEXIT{
SET TP1 = TP();
SET MA = WMA(TP1,50);
SET SI1 = SI(2);
SET MA1 = EMA(SI1,21);
CROSSOVER(TP1,MA) AND REF(MA1,1) < 0.01 AND REF(CLOSE,1) > REF(OPEN,1);}

This slideshow requires JavaScript.

Advertisements